升級到VMware vSphere 6.7 Update 1需要注意的事項

TIFY2018-11-08 16:23:06

       隨著VMware vSphere 6.7 Update 1的發佈及其下載的可用性,很多客戶開始計劃將現有vSphere環境更新到新的vSphere 6.7 Update 1。新的vSphere 6.7 Update 1發行版包含許多出色的新功能,可將vSphere環境提升到更高級別的功能。VMware確實大大簡化了過程,Update Manager的新功能需要更多的關注。

      在考慮將現有環境升級到vSphere 6.7 Update 1時,在將vSphere環境升級到最新版本之前需要考慮哪些關鍵因素?

      在本文中,我們將詳細介紹這些關鍵注意事項以及將vSphere版本成功升級到vSphere 6.7 Update 1的過程。

vSphere升級步驟概述

在考慮升級現有vSphere環境時,在執行vCenter Server和ESXi主機升級之前要考慮的一些關鍵考慮因素是什麼?

升級前需要考慮以下要點:

  • 閱讀新的vSphere版本說明

    • 這包括閱讀vCenter Server和ESXi虛擬機監控程序的發行說明

  • 備份你的配置

    • 確保具有vCenter和ESXi主機的配置備份

  • 在執行升級之前,請檢查以確保與其他vSphere或第三方產品兼容。通常,在發佈新的vSphere版本時,並非所有VMware解決方案都立即兼容。某些解決方案需要新版本以確保兼容性

    • 使用VMware互操作性表來確定VMware解決方案和產品之間的互操作性

  • 如果使用的是外部Platform Services     Controller,請將Platform     Services Controller設備6.0升級到版本6.7

  • 將vCenter Server升級到vSphere 6.7 Update 1 - 這是一個非常重要的步驟,因為它允許選擇支持的升級方法,具體取決於你使用的版本

    • 必須首先確保當前部署支持升級或遷移到vCenter Server 6.7      Update 1部署

    • 使用圖形部署工具 - 這允許通過兩步流程升級vCenter Server,首先將新VCSA設備部署為OVA,然後將現有數據複製到新設備,然後假設該身份

    • 使用遷移助手界面 - 這允許從舊版SSO平臺服務控制器或Windows上的vCenter Server遷移到VCSA設備

    • 使用CLI安裝程序 - 這允許高級用戶將Windows上的VCSA設備或vCenter Server升級到最新版本

    • 使用vCenter Admin VAMI界面 - 這是VCSA中的管理界面,允許將設備修補到主要版本中的最新版本

vCenter Server升級過程的高級概述(圖片由VMware提供)

  • 升級ESXi主機 - 升級vCenter Server後,升級群集主機上的ESXi虛擬機監控程序。vCenter Server必須與其管理的ESXi主機處於同一級別或更高級別。通常,客戶希望將ESXi版本與vCenter版本保持同步。但是,值得一提的是,最新的vCenter Server 6.7 Update     1支持管理低級ESXi主機

    • 如下所示,vCenter Server 6.7      Update 1支持管理ESXi主機,一直到6.0版。客戶可能會選擇這樣做。通過使用最新的vCenter Server版本,可以獲得最新的HTML 5界面。但是,從vSphere 6.7開始,VMware已棄用ESXi對舊版Windows Server(例如2003)的支持。如果客戶正在運行舊版Windows Server操作系統,則可能是使用低級ESXi主機版本/ li運行最新vCenter的原因>

VMware ProductInteroperability Matrix顯示支持的ESXi虛擬機管理程序版本

  • 升級虛擬機VMware Tools - 雖然VMware已將VMware Tools版本與vSphere版本本身分離,但如果為ESXi虛擬機管理程序下載選擇此選項,則新版本的vSphere通常會附帶VMware Tools的更新版本。升級vCenter Server和ESXi主機後,需要瀏覽虛擬機並升級VMware工具。這可以在vSphere中手動完成,也可以使用PowerCLI以編程方式輕鬆完成

  • 升級虛擬機兼容性 - 這是一個肯定不需要的步驟,但是,如果有新的虛擬硬件功能或其他配置要解除您希望利用的新vSphere版本,則需要升級虛擬硬件兼容性

通過執行上述步驟,可以平穩有效地將vSphere環境升級到包括vSphere 6.7 Update 1在內的最新版本。

還有哪些其他考慮因素?

升級vSphere之前的其他升級注意事項

在升級vSphere之前還有其他需要考慮的事項嗎?

      升級vSphere版本之前要考慮的另一個非常重要的考慮因素是確保選擇的備份解決方案支持vSphere版本。如果你的數據能夠成功將vSphere升級到最新版本,但發現你的數據保護解決方案無法使用vSphere進行備份,複製或執行其他操作,那將是非常令人沮喪和危險的。

為什麼新版本經常會破壞備份?

     數據保護解決方案依賴於能夠與vSphere中的備份API進行交互。對於新版本和發行版,VMware有時會改變API的工作方式或完全更改API。一旦升級發生,如果數據保護解決方案未設計為能夠處理新API,則作業通常會因雜項錯誤而失敗。因此,確保與數據保護解決方案之前的兼容性是關鍵,以確保它們與升級到的版本兼容,例如vSphere 6.7 Update 1。

     根據我們與vCenter Server交互的數據保護解決方案所討論的內容,根據你來自的版本,依靠vCenter Server所需的停機時間。只需使用GUI工具兩步過程進行升級過程,就可以從VAMI修補vCenter。如果擁有與vCenter Server集成的監控解決方案或其他第三方產品,那麼在vCenter正在進行升級時,也要考慮這些解決方案所需的停機時間。雖然虛擬機本身仍然可用,但如果依賴監控vCenter的掛鉤解決方案,請確保能夠承受“盲目飛行”的時間。

結論性思考

     通過徹底規劃vSphere環境升級,嚴格按照開頭中列出的步驟進行操作,可以儘可能順利地執行vSphere升級。有許多關鍵點需要考慮,例如安裝順序,驗證其他VMware解決方案和產品是否兼容,升級vCenter Server,在ESXi主機上執行升級以及從虛擬機管理程序中選擇運行的版本以及升級虛擬機器VMware Tools和兼容性。其他注意事項非常重要,例如確保你的數據保護解決方案與新版本的vSphere兼容,並期望與其他解決方案或與VMware vCenter集成的產品停機。在升級維護窗口期間,這些解決方案將無法連接到vCenter。

      VMware vSphere 6.7 Update 1是vSphere的首選版本,它提供了先進的企業數據中心技術,使組織能夠擁有當前和未來基礎架構需求所需的功能和特性。毫無疑問,這將是許多組織針對升級舊版vSphere環境所針對的版本。通過適當的規劃,執行以及預先考慮所有因素,升級無疑將順利進行

閱讀原文

TAGS: